Configure Vlan on Vmware and Dynamips : step by step

From mmliac in hacki forum :

I have tested trunking between two 3660 with NM-16ESW and it works fine.
Connected 3 Wmware computers on each side in 2 different vlans.
Vlan information is being transferred from the VTP server to the VTP client.

I am using Vmware Workstation 5.0 and Dynamips is running on the host computer

Heres step by step configure vlan on vmware and dynamips :

Start by configuring new virtual interfaces in Vmware.

vlan

The window Virtual Network Editor should open.

Chose [Host Virtual Adapters]

Press the [Add] button and chose witch “network” card to add.

Do not choose VMnet0 VMnet1 and VMnet8.

Add as many cards you need for your lab.

Press [Ok]

They should come up as host only in [Summary]

Restart your computer.

Install Windows XP in Vmware and clone as many as you need.

In Vmware press edit virtual machine settings

vlan

Choose Ethernet

Press Custom Specific Network and choose the virtual network card you want to use for that Vmware computer.

Start Vmware computer and configure IP settings.

Configure IP settings on the corresponding Virtual network card on the real computer.

I have done it like this

VMnet card on host Network card on Wmware computer

VMnet Card IP Computer IP

VMnet2 192.168.20.101/24 XP1 192.168.20.201/24

VMnet3 192.168.20.102/24 XP2 192.168.20.202/24

VMnet4 192.168.20.103/24 XP3 192.168.20.203/24

And so on…..

Now we have to configure Dynamips

This is the .net file I have used

# Test 3660 Switch

[localhost]

[[3660]]

image = C:\Programfiler\Dynamips\images\Your image file

ram = 160

disk0 = 64

mmap = false

ghostios = True

idlepc = Your Idle PC data

################# Router R1 #################

[[ROUTER R1]]

model = 3660

slot1 = NM-16ESW

# VMnet2

f1/0 = NIO_gen_eth:\Device\NPF_{Your card ID*}

# VMnet3

f1/1 = NIO_gen_eth:\Device\NPF_{Your card ID*}

# VMnet4

f1/2 = NIO_gen_eth:\Device\NPF_{Your card ID*}

# Trunk

f1/15 = R2 f1/15

################# Router R2 #################

[[ROUTER R2]]

model = 3660

slot1 = NM-16ESW

# VMnet5

f1/0 = NIO_gen_eth:\Device\NPF_{ Your card ID*}

# VMnet6

f1/1 = NIO_gen_eth:\Device\NPF_{ Your card ID*}

# VMnet7

f1/2 = NIO_gen_eth:\Device\NPF_{ Your card ID*}

* To find out Your card id use network device list program


Time to configure the router/switch Router1

Configure the router as VTP server

Router1#Vlan database

Router1(vlan)#vtp server

Router1(vlan)#vtp domain test

Router1(vlan)#vtp password test

Add 2 new Vlans

Router1(vlan)#vlan 2 name A

Router1(vlan)#vlan 3 name B

Router1(vlan)#apply

Router1(vlan)#exit

Configure the interfaces in different vlans

Router1(config)#interface FastEthernet1/0

Router1(config-if)# switchport access vlan 2

Router1(config-if)# duplex full

Router1(config-if)# speed 100

Router1(config-if)# no shutdown

Router1(config)#interface FastEthernet1/1

Route1r(config-if)# switchport access vlan 2

Router1(config-if)# duplex full

Router1(config-if)# speed 100

Router1(config-if)# no shutdown

Router1(config)#interface FastEthernet1/2

Router1(config-if)# switchport access vlan 3

Router1(config-if)# duplex full

Router1(config-if)# speed 100

Router1(config-if)# no shutdown

Router1(config)#interface FastEthernet1/15

Router1(config)#switchport mode trunk

Router1(config-if)# no shutdown

Time to configure the router/switch Router2


Configure the router as VTP client

Router2#Vlan database

Router2(vlan)#vtp client

Router2(vlan)#vtp domain test

Router2(vlan)#apply

Router2(vlan)#exit

Configure the interfaces in different vlans

Router2(config)#interface FastEthernet1/0

Router2(config-if)# switchport access vlan 2

Router2(config-if)# duplex full

Router2(config-if)# speed 100

Router2(config-if)# no shutdown

Router2(config)#interface FastEthernet1/1

Router2(config-if)# switchport access vlan 2

Router2(config-if)# duplex full

Router2(config-if)# speed 100

Router2(config-if)# no shutdown

Router2(config)#interface FastEthernet1/2

Router2(config-if)# switchport access vlan 3

Router2(config-if)# duplex full

Router2(config-if)# speed 100

Router2(config-if)# no shutdown

Router2(config)#interface FastEthernet1/15

Router2(config)#switchport mode trunk

Router2(config-if)# no shutdown

This worked fine for me.

I use Vmware 5.0 and Dynamips is not running in Vmware but on the host computer.

I hope this will help some one.

Source : NM-16ESW and vmware

Other resources :